Gerne beraten wir Sie auch telefonisch & geben Ihnen eine kostenfreie persönliche Auskunft zu Ihrem Projekt.

X

Statistik mit Excel: So gelingen aussagekräftige Analysen

Daten werden zum einen oft in Tabellen gesammelt. Zum anderen bieten viele Softwarepakete die Möglichkeit, Informationen in Excel- oder CSV-Dateien zu exportieren. Da liegt es doch nahe, die Daten auch gleich mit Excel auszuwerten. Da verwandte Programme (LibreOffice, Apache OpenOffice, etc.) überwiegend die gleichen Funktionen bieten, lässt sich zudem nahezu alles, was wir zum Thema Statistik mit Excel hier zeigen, auch auf andere Programme zur Tabellenkalkulation übertragen.

Sie möchten eine Excel Statistik erstellen und benötigen Hilfe bei der Formelerstellung oder für eine statistische Auswertung mit Excel? – Dann wenden sie sich hierzu an uns für eine professionelle Beratung.

Lassen Sie uns Ihre Anforderungen wissen & wir erstellen Ihnen innerhalb weniger Stunden ein kostenfreies Angebot.


Jetzt unverbindlich anfragen

Der folgende Artikel nennt grundlegende Funktionen zur Excel Statistik und beantwortet dabei folgende Fragen:

  • Was sind die wichtigsten Formeln und Statistikfunktionen Excel?
  • Was bedeuten ZÄHLENWENN und SUMMEWENN?
  • Wie gelingt es, mit Excel Streuung und Mittelwert berechnen?
  • Wo liegen die Grenzen von Excel?

Mit Excel Statistik erstellen: Die wichtigsten Formeln

Excel kennt eine ganze Reihe von Formeln, mit denen sich Daten statistisch auswerten lassen. Damit lassen sich fast alle wichtigen Kennzahlen der deskriptiven Statistik – vom arithmetischen Mittel bis zur Standardabweichung – problemlos berechnen.

So etwa könnte der Beginn einer Tabelle aussehen. Stellen wir uns einfach vor, wir hätten noch 121 weitere Datensätze, die letzte mit Daten gefüllte Zeile wäre dann 125.

Wichtig ist, dass wir in Excel verschiedene Formeln kombinieren und verschachteln können. Beispielsweise lässt sich in eine Formel als Kriterium ein ODER einsetzen. Dann wird die Funktion ausgeführt, wenn eines von verschiedenen Kriterien erfüllt ist. Genauso können wir auch die Formel UND verwenden, dann müssen verschiedene Bedingungen gleichzeitig gelten.

Eine häufige Fehlerquelle ist das Fehlen von Anführungszeichen in Formeln. Ist das Kriterium für eine Formel eine Zahl, sind keine Anführungszeichen nötig. Handelt es sich dagegen um einen Text, müssen wir diesen in Anführungszeichen setzen.

Anführungszeichen sind auch nötig, wenn etwa Zeichen wie < oder > für kleiner oder größer als verwendet werden. Wollen wir etwa Werte größer oder gleich 4 suchen, so schreiben wir als Kriterium “>=4“. Soll der Wert dagegen genau gleich 4 sein, so setzen wir keine Anführungszeichen.

Mit Excel Statistik erstellen: Häufigkeiten und Summen

Häufigkeiten und Summen lassen sich mit Excel einfach auswerten. Nachfolgende Tabelle zeigt einen kurzen Überblick über die Formeln für Auszählen und Summen:

Auszählen, falls eine Bedingung erfüllt ist: =ZÄHLENWENN()
Auszählen, falls mehrere Bedingungen in verschiedenen Spalten erfüllt sind: =ZÄHLENWENNS()
Summe mehrerer Zahlen: =SUMME()
Summe, falls eine Bedingung erfüllt ist: =SUMMEWENN()
Summe, falls mehrere Bedingungen und verschiedenen Spalten erfüllt sind: =SUMMEWENNS()

Häufigkeiten und Summen sind zwar einfache, aber trotzdem wichtige Bausteine bei der Auswertung von Daten. Ein Beispiel: Nehmen wir an, es gilt die Zahl der Mitarbeitenden in Vollzeit festzustellen. Das ist mit der Formel =ZÄHLENWENN() kein Problem. In die Klammer geben wir dabei zunächst den Bereich, in dem gezählt werden soll, und dann anschließend das Kriterium.

Das Kriterium kann in unserer Tabelle mit einer Buchstabenkombination oder einer Zahl codiert sein. Denkbar ist auch, dass der Begriff „Vollzeit“ ausgeschrieben ist, es kann dort aber nur eine Abkürzung wie „VZ“ stehen oder auch eine Zahl, beispielsweise 1 für Vollzeit, 2 für sozialversicherungspflichtige Teilzeit und 3 für einen Minijob.

Stehen unsere Daten in den Zellen C2 bis C125, so lautet die Formel also =ZÄHLENWENN(C1:C125;1). Wäre Vollzeit dagegen in den Zellen ausgeschrieben, so schreiben wir statt einer 1 Vollzeit, wobei wir das Wort in Anführungszeichen setzen müssen, also =ZÄHLENWENN(C1:C125;“Vollzeit“).

Sollen mehrere Kriterien in unterschiedlichen Spalten gleichzeitig erfüllt sein, müssen wir an den Namen der Formel nur ein ‚S‘ anhängen. Mit =ZÄHLENWENNS() können wir mehrere Spalten gleichzeitig definieren und für jede Spalte jeweils wieder ein eigenes Kriterium nennen. So lässt sich beispielsweise herausfinden, wie viele Angestellte Vollzeit und gleichzeitig Schicht arbeiten – oder wer Vollzeit arbeitet, Schicht arbeitet und weiblich ist.

Excel Formel: SUMME

Die Formel =SUMME() kennen fast alle, die mit Excel arbeiten. Manchmal aber soll die Summe nicht über alle Werte hinweg gebildet werden, sondern nur, sofern bestimmte Bedingungen erfüllt sind. Das gelingt einfach mit der Formel =SUMMEWENN(). Wollen wir die Arbeitszeit aller Beschäftigten in Teilzeit addieren, gibt es in unserer Beispieltabelle zwei Möglichkeiten.

Eine Möglichkeit ist, alle Zellen aus der Spalte mit der Arbeitszeit zu addieren, bei denen in der Spalte zur Arbeitszeitregelung „TEILZEIT“ eingetragen ist. Dazu definieren wir in der Klammer zunächst den Bereich, in dem die Arbeitszeitregelung erfasst ist, danach definieren wir als Kriterium „TEILZEIT“ und legen zuletzt den Bereich fest, dessen Zellen wir addieren wollen.

Die Formel könnte dann beispielsweise lauten =SUMMEWENN(C1:C325;“TEILZEIT“; D1:D325). Es werden somit alle Zellen der Spalte D addiert, bei denen in Spalte C in der jeweils gleichen Zeile „TEILZEIT“ vermerkt ist.

Sofern alle Vollzeitbeschäftigten mindestens eine bestimmte Arbeitszeit, beispielweise 35 Stunden, arbeiten, gibt es noch eine zweite Möglichkeit: Dazu addieren wir einfach alle Zahlen, deren Wert größer als 35 ist. Die Formel dazu lautet: =SUMMEWENN(D1:D325;“>35“).

Die Angabe zu dem Bereich, der addiert werden muss, entfällt. Folglich verwendet Excel zum Addieren die gleiche Spalte wie für die Kriterien. Auch hier haben wir wieder die Möglichkeit, mehrere Kriterien zu definieren, die gleichzeitig erfüllt sein müssen, wenn wir ein ‚S‘ an den Namen anhängen, also =SUMMEWENNS().

Dazu muss allerdings ganz vorne der Summenbereich stehen, dann folgt das erste Kriterium, schließlich der erste Kriterienbereich. Nun lassen sich weitere Kriterien und weitere Kriterienbereiche definieren.

Mittelwert berechnen: Excel hilft

Zum Thema Statistik mit Excel gehört natürlich auch das Mittelwert berechnen. Excel ermittelt das arithmetische Mittel, oft als Durchschnitt bezeichnet, mit der Formel =MITTELWERT().

Mit der Formel =GEOMITTEL() lässt sich das geometrische Mittel berechnen. Dies benötigt man beispielsweise, um Durchschnitte bei Wachstumswerten (zB. Nutzungskennzahlen über mehrere Jahre) oder Zinsen zu bestimmen.

Auch der Median, der eine Datenreihe in zwei gleich große Teile teilt, sowie der Modalwert, der häufigste Wert, lassen sich mit Excel einfach und rasch bestimmen. Nachfolgende Tabelle gibt eine Übersicht über wichtige Parameter rund um Mittelwert berechnen. Die Excel Formel findet sich entsprechend in der rechten Spalte.

Arithmetisches Mittel: =MITTELWERT()
Geometrisches Mittel: =GEOMITTEL()
Median: = MEDIAN()
Modalwert: = MODALWERT()

Statistik mit Excel: Standardabweichung berechnen

Excel kennt zur Berechnung der Standardabweichung zwei unterschiedliche Kennwerte. Die Formel =STABW.N() entspricht der klassischen Standardabweichung. Wollen wir etwa die Streuung der Einkommen aller Beschäftigten oder der Tagesumsätze über ein Jahr hinweg berechnen, so liegen wir mit dieser Formel richtig.

Liegt nur eine einzelne Stichprobe vor, benötigen wir die Formel STABW.S(). Die Standardabweichung ist dann etwas größer, weil bei der Berechnung der Varianz (deren Wurzel die Standardabweichung ist) nicht durch die Zahl der Fälle geteilt wird, sondern immer durch einen um 1 kleineren Wert. Bei 100 Fällen etwa durch 99.

Neben den Excel-Formeln zu Standardabweichung und Mittelwert berechnen, sind auch Korrelationskoeffizienten einfache und gut zu interpretierende Maße, mit denen wir mittels Excel den Zusammenhang zwischen zwei Variablen bestimmen können. Hier hilft die Formel =KORREL(). Eine ausführliche Beschreibung dazu findet sich in einem früheren Beitrag zu Korrelationsanalysen in EXCEL.

Grenzen von Excel: Komplexe Berechnungen und Big Data

Komplexere Berechnungen sind in Excel meist nicht mehr durchführbar. Schon bei einer Regressionsanalyse sind spezielle Statistik-Programme wie SPSS oder R besser geeignet. Zwar verwendet Excel zur Berechnung einer linearen Trendgerade eine OLS-Regression, wie in der nachfolgenden Abbildung visualisiert. Die Möglichkeiten sind dabei aber äußerst begrenzt.

Für große Datenmengen ist Statistik mit Excel ebenso nur bedingt geeignet. Dabei sind es weniger lange Zahlenreihen, die Dateien groß werden lassen, sondern vor allem die Berechnungen und Verweise. Oft lässt sich die Größe einer Datei deutlich reduzieren, indem wir Formeln in Werte umgewandeln.

Wichtig: Ist der Wert in Spalte A beispielsweise als die Summe der Werte in Spalte B und C definiert, lässt sich die Dateigröße verringern, wenn die Ergebnisse zunächst kopiert und dann mithilfe der Funktion „Inhalte einfügen“ mit den Ergebniswerten überschrieben werden.

Abbildung: Mit der rechten Maustaste kann das Menü „Inhalte einfügen“ aufgerufen werden. Dort Werte auswählen und Formeln mit den Werten überschreiben, die zuvor kopiert wurden.

Eine Übersicht dazu bzw. zu weiteren Formeln findet sich im Microsoft Support hier.

Fazit

In diesem Beitrag haben wir gelernt: Statistik mit Excel zu erstellen bringt Vor- und Nachteile mit sich. Excel ist leicht zu bedienen und meist fallen keine Kosten für Softwarepakete an, da Excel entweder ohnehin vorhanden ist oder kostenlose Alternativen wie LibreOffice oder Apache OpenOffice die überwiegend gleichen Funktionen bieten.

Bei größeren Datenmengen oder komplexen Auswertungen ist eine klassische Statistiksoftware aber besser geeignet. Tabellenblätter lassen sich dafür leicht importieren, entweder direkt als Excel-Datei oder als CSV-Datei.

Bei weiteren Fragen zur Nutzung und Umsetzung von Statistik mit Excel oder zu alternativer Statistiksoftware zur Lösung Ihrer Aufgabenstellung wenden Sie sich einfach an uns. Nutzen Sie dazu einfach und unverbindlich unser Anfrageformular. Wir unterstützen Sie gerne!

Jetzt Anrufen Jetzt anfragen